Routing Static Dynamics RIP OSPF IGRP EIGRP

How to configure enhanced interior gateway routing protocol

EIGRP is a Cisco-proprietary routing protocol for TCP/IP. It's actually based on Cisco's proprietary IGRP routing protocol, with many enhancements built into it. Because it has its roots in IGRP, the configuration is similar to IGRP; however, it has many link state characteristics that were added to it to allow EIGRP to scale to enterprise network sizes. To know these characteristics read our previous article.

In this article I will demonstrate an example of EIGRP Routing configurations. We will use four different series router so you can get familiar with all different platform covered in CCNA exam. Create a topology as shown in figure.

static route configurations

1841 Series Router0 (R1)
FastEthernet0/0 Serial0/0/0
IP address 10.0.0.1 20.0.0.1
Connected With Pc0 R2 on Serial 0/0
2811 Series Router0 (R4)
FastEthernet0/0 Serial0/0/0
IP address 50.0.0.1 40.0.0.2
Connected With Pc1 R3 on Serial 0/0
2621XM Series Router0 (R3)
FastEthernet0/0 Serial0/0/0
IP address 30.0.0.2 40.0.0.1
Connected With FastEthernet0/0 R4 on Serial 0/0/0
2620XM Series Router1 (R2)
FastEthernet0/0 Serial0/0
IP address 30.0.0.1 20.0.0.2
Connected With R3 on FastEthernet0/0 R1 on Serial 0/0/0
PC-PT PC0
FastEthernet0 Default Gateway
IP address 10.0.0.2 10.0.0.1
Connected With R1 on FastEthernet0/0
PC-PT PC1
FastEthernet0 Default Gateway
IP address 50.0.0.2 50.0.0.1
Connected With R4 on FastEthernet0/0

To configure any router double click on it and select CLI.To configure this topology use this step by step guide.

(1841Router0) Hostname R1

To configure and enable eigrp routing on R1 follow these commands exactly.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
R1(config)#

(2620XM-Router1) Hostname R2

To configure and enable eigrp routing on R2 follow these commands exactly.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#router eigrp 1
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
R2(config)#

(2620XM-Router2)Hostname R3

To configure and enable eigrp routing on R3 follow these commands exactly.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial 0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
R3(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config)#router eigrp 1
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

(2811Router3) Hostname R4

To configure and enable eigrp routing on R4 follow these commands exactly.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
R3(config)#router eigrp 1
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

PC-1

PC>ipconfig

IP Address......................: 10.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 10.0.0.1

PC>ping 50.0.0.2

Pinging 50.0.0.2 with 32 bytes of data:

Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=127ms TTL=124
Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=140ms TTL=124

Ping statistics for 50.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 127ms, Maximum = 156ms, Average = 144ms
PC>

PC-2

PC>ipconfig

IP Address......................: 50.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 50.0.0.1

PC>ping 10.0.0.2

Pinging 10.0.0.2 with 32 bytes of data:

Reply from 10.0.0.2: bytes=32 time=140ms TTL=124
Reply from 10.0.0.2: bytes=32 time=141ms TTL=124
Reply from 10.0.0.2: bytes=32 time=157ms TTL=124
Reply from 10.0.0.2: bytes=32 time=156ms TTL=124

Ping statistics for 10.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 140ms, Maximum = 157ms, Average = 148ms

You can verify that eigrp is running successfully via show ip protocols command in privilege mode.

R4#show ip protocols

Routing Protocol is "ospf 4"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 50.0.0.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    50.0.0.0 0.255.255.255 area 0
    40.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    40.0.0.1             110      00:01:26
  Distance: (default is 110)

R4#

You can use show ip route command to troubleshoot eigrp network. If you did not see information about any route checks the router attached with that network.

R4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O    10.0.0.0/8 [110/1564] via 40.0.0.1, 00:02:37, Serial0/0/0
O    20.0.0.0/8 [110/1563] via 40.0.0.1, 00:02:37, Serial0/0/0
O    30.0.0.0/8 [110/782] via 40.0.0.1, 00:02:37, Serial0/0/0
C    40.0.0.0/8 is directly connected, Serial0/0/0
C    50.0.0.0/8 is directly connected, FastEthernet0/0
R4#

To test eigrp routing do ping from pc1 to pc2 and vice versa. If you get replay then you have successfully configured eigrp routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake

eigrp routing configurations

Configuration command of EIGRP

Commands Descriptions

Router(config)#router eigrp 1

Turns on the EIGRP process. 1 is the autonomous system number, which can be a number between 1 and 65,535.

Note:- All routers in the same autonomous system must use the same autonomous system number.

Router(config-router)#network 10.0.0.0

Specifies which network to advertise in EIGRP.

Router(config-if)#bandwidth x

Sets the bandwidth of this interface to x kilobits to allow EIGRP to make a better metric calculation

TIP: The bandwidth command is used for metric calculations only. It does not change interface performance.

Router(config-router)#no network 10.0.0.0

Removes the network from the EIGRP process.

Router(config)#no router eigrp 1

Disables routing process 1

Router(config-router)#auto-summary

Enables auto-summarization for the EIGRP process.

Router(config-router)#no autosummary

Turns off the auto-summarization feature.

Router(config-router)#variance n

include routes with a metric less than or equal to n times the minimum metric route for that destination, where n is the number specified by the variance command

NOTE: If a path is not a feasible successor, it is not used in load balancing. EIGRP supports up to six unequal-cost paths.

Router(config)#interface serial 0/0

Enters interface configuration mode.

Router(config-if)#bandwidth 256

Sets the bandwidth of this interface to 256 kilobits to allow EIGRP to make a better metric calculation.

Router#show ip eigrp neighbors

Displays the neighbor table.

Router#show ip eigrp neighbors detail

Displays a detailed neighbor table.

Router#show ip eigrp interfaces

Shows information for each interface

Router#show ip eigrp interfaces serial 0/0

Shows information for a specific interface

Router#show ip eigrp interfaces 1

Shows information for interfaces running process 1.

Router#show ip eigrp topology

Displays the topology table

Router#show ip eigrp traffic

Shows the number and type of packets sent and received

Router#show ip route eigrp

Shows a routing table with only EIGRP entries

Router#debug eigrp fsm

Displays events/actions related to EIGRP feasible successor metrics (FSM)

Router#debug eigrp packet

Displays events/actions related to EIGRP packets

Router#debug eigrp neighbor

Displays events/actions related to your EIGRP neighbors

Router#debug ip eigrp neighbor

Displays events/actions related to your EIGRP neighbors

Router#debug ip eigrp notifications

Displays EIGRP event notifications

Written by Admin

Follow us

Contact us

Write for us

We are always on the lookout for new talent and ideas. We provide you a platform to share your ideas and knowledge with the world while developing a name for yourself as an expert in your field. We encourage you to learn more and submit a article!

Advertise With us

Reach millions of global audience including network administrator and system admin. Advertising on ComputerNetworkingNotes.com will allow your company to tap into one of the largest online communities of computer networking.

Report an issue

We greatly appreciate our visitors helping us to find issues with the site. we will investigate your report and use the information you provide to improve our site.

Other reason

We love to hear from you! Regardless of the type of feedback, we are always ready to assist you.